Currently the products that will support use of ChartSelect™ will be the following models:

1100 Series  

Software Version 7.460 or higher

  • 1159ci HD COMBO 
  • 1159CI HD DI COMBO
  • 1159CI HD XD COMBO
  • 1199CI HD SI COMBO

Software Version 7.510 or higher

 1198c SI

900 Series  

Software Version 7.460 or higher

  • 959ci HD COMBO
  • 959ci HD DI COMBO
  • 959ci HD XD COMBO
  • 999ci HD SI COMBO

Software Version 7.510 or higher

  • 998c SI
  • 998c HD SI 

800 Series  

Software Version 7.460 or higher

  • 859ci HD COMBO
  • 859ci HD COMBO
  • 859ci HD XD COMBO
  • 899ci HD SI COMBO

Software Version 7.510 or higher 

  • 898c SI
  • 898c HD SI

700 Series  (Software Version 7.600 or higher)

  • 788ci HD
  • 788ci HD DI
  • 788ci HD XD
  • 798ci HD SI

600 Series  (Software Version 7.520 or higher)

  • 688ci HD
  • 688ci HD DI
  • 688ci HD XD
  • 698ci HD SI

HELIX 5 Series  (Software Version 7.520 or higher)

  • HELIX 5 SONAR GPS
  • HELIX 5 DI GPS
  • HELIX 5 SI GPS
  • HELIX 5 CHIRP GPS G2 - supports Multilayers
  • HELIX 5 CHIRP DI GPS G2 - supports Multilayers
  • HELIX 5 CHIRP SI GPS G2 - supports Multilayers

HELIX 7 Series

  • HELIX 7 SONAR GPS
  • HELIX 7 DI GPS
  • HELIX 7 SI GPS
  • HELIX 7 SI GPS KVD
  • HELIX 7 CHIRP GPS G2-  supports Multilayers
  • HELIX 7 CHIRP GPS G2N -  supports Multilayers
  • HELIX 7 CHIRP DI GPS G2 -  supports Multilayers
  • HELIX 7 CHIRP DI GPS G2N-  supports Multilayers
  • HELIX 7 CHIRP SI GPS G2 -  supports Multilayers
  • HELIX 7 CHIRP SI GPS G2N -  supports Multilayers

HELIX 9 Series  - All models

HELIX 10 Series  - All models

HELIX 12 Series  - All models

ONIX Series  - All models (Software version 2.000 or higher)

ION Series  - All models (Software version 2.000 or higher)

SOLIX Series  - All models

Updated:  February 15, 2017