v2.070 - this release is required for use with Humminbird products at software release 6.900 or higher or ONIX products

  • This supports the use of AutoChart or AutoChart Pro. 
  • This release corrects issues where the i-Pilot Link remote was not updating correctly on ONIX products. 
  • Fixed a bug that affected resuming iTrack navigation if Spot Lock was used during iTrack navigation.
  • Fixed a bug related to using Follow the Contour offsets with a ZeroLine map card.  

Below are additional explanations on how these various versions of software work together on a system or networked systems.

i-Pilot Link Controller version 1.160 and Remote version 1.160 should be used on Humminbird products which are at software version 6.840 through 6.890.   These files are .bin files and can only be accepted by our core Humminbird products.  Example, our 800/900/1100 Series of products

i-Pilot Link Controller version  2.070 and Remote version 2.020 that are .bin files should be used on core Humminbird products that are running software versions 6.900 or higher.

i-Pilot Link Controller version 2.070 and Remote version 2.020 that are .pkg files should be used with the Humminbird ONIX and ION Series of products only. 

With product networking, this can create various combinations of products and software versions.  Here is what you can expect if your Humminbird products are on varying software versions. 

What if I have a unit running 6.890 or prior on the same network with a unit running 6.900 or later?

If you have two or more Humminbird control heads and one is running 6.890 or earlier and one is running 6.900 and later both units will not be able to use the i-Pilot Link at the same time.

You must decide which unit you want to use with i-Pilot Link until a 6.900 or later software upgrade is available for both of your units.

If you select the unit with 6.890 and prior you should run your i-Pilot Link Controller and Remote with the older software version.

  • 1.160 i-Pilot Link Controller Firmware
  • 1.160 i-Pilot Link Remote Firmware

If you select the unit with 6.900 and later you should run your i-Pilot Link Controller and Remote with the newer software version.

  • 2.070 i-Pilot Link Controller Firmware
  • 2.020 i-Pilot Link Remote Firmware

The unit that you do not choose to use with i-Pilot Link may show some adverse behavior if you try to use it with i-Pilot Link.  It may show that the i-Pilot Link is connected and even show the software version but it will not function correctly.  Attempting to select i-Pilot Link features from the Humminbird menus will not engage the i-Pilot Link functions.

i-Pilot Link functions engaged on the supported unit and/or remote will not function or show navigation correctly on the unit that is not supported.